Saturday, March 21, 2009

Gem Install Facebooker on Windows

If you run "gem install faceboooker", you'll get this:


C:\Users\treeder>gem install -f facebooker
Building native extensions. This could take a while...
ERROR: Error installing facebooker:
ERROR: Failed to build gem native extension.

c:/ruby/bin/ruby.exe extconf.rb install -f facebooker
creating Makefile

nmake
'nmake' is not recognized as an internal or external command,
operable program or batch file.

Gem files will remain installed in c:/ruby/lib/ruby/gems/1.8/gems/json-1.1.3 for
inspection.
Results logged to c:/ruby/lib/ruby/gems/1.8/gems/json-1.1.3/ext/json/ext/parser/
gem_make.out

To fix this:
  1. gem install json -v 1.1.1 (only one that works on windows at time of posting, json_pure doesn't work with rails 2.3)
  2. gem install facebooker --ignore-depencies